Pipeline Failures Due to Variable Validation and Transformation Errors

Incident Report for Matillion Services

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 15:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2025 - 15:48 UTC

Identified

The issue has been identified and a fix is in testing phase
Posted Oct 15, 2025 - 15:19 UTC

Update

We are continuing to actively investigate this issue.
Posted Oct 15, 2025 - 12:10 UTC

Update

We are continuing to actively investigate this issue.
Posted Oct 15, 2025 - 08:37 UTC

Investigating

Customers may experience unexpected behavior with how variables are validated and processed.
Posted Oct 15, 2025 - 00:13 UTC
This incident affected: EU Region (Pipeline Execution) and US Region (Pipeline Execution).