Projects unavailable within US region
Incident Report for Matillion Services
Resolved
The incident has been resolved.
Posted Jul 18, 2024 - 09:02 UTC
Investigating
Users in US locations may experience issues accessing projects
Posted Jul 18, 2024 - 08:43 UTC
This incident affected: US Region (Designer).