Login Issues with Matillion Hub

Incident Report for Matillion Services

Resolved

This incident is now resolved
Posted Oct 20, 2025 - 12:31 UTC

Update

We are continue to monitor for any further issues.
Posted Oct 20, 2025 - 12:03 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 11:15 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 11:01 UTC

Monitoring

Starting from approximately 08:00 BST, some customers may experience errors or been unable to log in to the Matillion Hub. We are investigating this and partial service has been restored currently
Posted Oct 20, 2025 - 10:13 UTC
This incident affected: Hub.