Hub is down

Incident Report for Matillion Services

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 08:24 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 13, 2025 - 08:05 UTC

Investigating

We are aware of an issue where customers are unable to select their account when logging in or when trying to switch between accounts. Direct links to an account are still operational, and all scheduled pipelines are unaffected.
Posted Jun 13, 2025 - 08:04 UTC
This incident affected: Hub.