Pipeline executions Failing due to empty variable

Incident Report for Matillion Services

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 20:06 UTC

Update

Issue resolved.
Posted Sep 29, 2025 - 19:50 UTC

Investigating

We've identified where if you are passing a variable that is null or empty as a post-processing output, it will cause the component to fail. We are working on a fix.
Posted Sep 29, 2025 - 18:07 UTC
This incident affected: EU Region (Pipeline Execution) and US Region (Pipeline Execution).